Vulnerability · Published Apr 21, 2026 · Assigned by GitHub_M
CVE-2026-40606ProxyAuth Addon LDAP Injection in mitmproxy
Medium 4.8
In plain English
A medium-severity security flaw in mitmproxy from mitmproxy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmproxy 12.2.1 and below, the builtin LDAP proxy authentication does not correctly sanitize the username when querying the LDAP server. This allows a malicious client to bypass authentication. Only mitmproxy instances using the proxyauth option with LDAP are affected. This option is not enabled by default. The vulnerability has been fixed in mitmproxy 12.2.2 and above.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | mitmproxy | no fix listed | DEBIAN-CVE-2026-40606 |
| Debian:14 | mitmproxy | no fix listed | DEBIAN-CVE-2026-40606 |
| PyPI | mitmproxy | 12.2.2 | GHSA-527g-3w9m-29hv |
| PyPI | mitmproxy | 12.2.2 | PYSEC-2026-92 |
| Ubuntu:22.04:LTS | mitmproxy | no fix listed | UBUNTU-CVE-2026-40606 |
| Ubuntu:24.04:LTS | mitmproxy | no fix listed | UBUNTU-CVE-2026-40606 |
| Ubuntu:25.10 | mitmproxy | no fix listed | UBUNTU-CVE-2026-40606 |
| Ubuntu:26.04:LTS | mitmproxy | no fix listed | UBUNTU-CVE-2026-40606 |
| Ubuntu:26.10 | mitmproxy | no fix listed | UBUNTU-CVE-2026-40606 |
Affected products (as reported)
Weakness: CWE-90 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/mitmproxy/mitmproxy/security/advisories/GHSA-527g-3w9m-29hv x_refsource_CONFIRM