Vulnerability · Published Apr 17, 2026 · Assigned by GitHub_M
CVE-2026-40476graphql-php: Denial of Service via quadratic complexity in OverlappingFieldsCanBeMerged validation
Medium 6.9
In plain English
A medium-severity security flaw in graphql-php from webonyx. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
graphql-go is a Go implementation of GraphQL. In versions 15.31.4 and below, the OverlappingFieldsCanBeMerged validation rule performs O(n²) pairwise comparisons of fields sharing the same response name. An attacker can send a query with thousands of repeated identical fields, causing excessive CPU usage during validation before execution begins. This is not mitigated by existing QueryDepth or QueryComplexity rules. This issue has been fixed in version 15.31.5.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | webonyx/graphql-php | 15.31.5 | GHSA-68jq-c3rv-pcrr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| webonyx | graphql-php | < 15.31.5 |
Weakness: CWE-407 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N