Vulnerability · Published Apr 17, 2026 · Assigned by GitHub_M
CVE-2026-40352FastGPT: NoSQL Injection in updatePasswordByOld Leads to Account Takeover
High 8.8
In plain English
A high-severity security flaw in FastGPT from labring. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities).
Official description
FastGPT is an AI Agent building platform. In versions prior to 4.14.9.5, the password change endpoint is vulnerable to NoSQL injection. An authenticated attacker can bypass the "old password" verification by injecting MongoDB query operators. This allows an attacker who has gained a low-privileged session to change the password of their account (or others if combined with ID manipulation) without knowing the current one, leading to full account takeover and persistence. This issue has been fixed in version 4.14.9.5.
Affected products (as reported)
Weakness: CWE-943 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/labring/FastGPT/security/advisories/GHSA-422w-vrfj-72g6 x_refsource_CONFIRM
- https://github.com/labring/FastGPT/commit/bd966d479fbe414d02679cf79f9eaaab3d100a2d x_refsource_MISC
- https://github.com/labring/FastGPT/releases/tag/v4.14.9.5 x_refsource_MISC