Vulnerability · Published Apr 10, 2026 · Assigned by GitHub_M
CVE-2026-40178ajenti.plugin.core has a race conditions in 2FA
Medium 6.9
In plain English
A medium-severity improper authentication in ajenti from ajenti. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
ajenti.plugin.core defines all necessary core elements to allow Ajenti to run properly. Prior to 0.112, if the 2FA was activated, it was possible during a short moment after the authentication of an user to bypass its authentication. This vulnerability is fixed in 0.112.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | ajenti-plugin-core | 0.112 | GHSA-8647-755q-fw9p |
| PyPI | ajenti-plugin-core | 0.112 | PYSEC-2026-2340 |
Affected products (as reported)
Weakness: CWE-287, CWE-362 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
References
- https://github.com/ajenti/ajenti/security/advisories/GHSA-8647-755q-fw9p x_refsource_CONFIRM