Vulnerability · Published Apr 27, 2026 · Assigned by apache
CVE-2026-40022Apache Camel Platform HTTP Main: Authentication Bypass on Non-Root Context Paths in camel main runtime
High 8.2
In plain English
A high-severity authentication bypass in Apache Camel Platform HTTP Main from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 61% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
When authentication is enabled on the Apache Camel embedded HTTP server or embedded management server (camel-platform-http-main) and a non-root context path such as /api or /admin is configured via camel.server.path or camel.management.path, the BasicAuthenticationConfigurer and JWTAuthenticationConfigurer classes derive the authentication path from properties.getPath() when camel.server.authenticationPath / camel.management.authenticationPath is not explicitly set. Combined with the Vert.x sub-router mounting model - the sub-router is mounted at _path_* and the authentication handler is registered inside the sub-router at the resolved path - this causes the authentication handler to match only the exact configured context path, not its subpaths. Unauthenticated requests to subpaths such as /api/_route_ or /admin/observe/info therefore reach protected business routes and management endpoints without being challenged for credentials. The /observe/info endpoint can disclose runtime metadata such as the user, working directory, home directory, process ID, JVM and operating system information. This issue affects Apache Camel: from 4.14.1 before 4.14.6, from 4.18.0 before 4.18.2. Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, they are suggested to upgrade to 4.14.6. If users are on the 4.18.x LTS releases stream, they are suggested to upgrade to 4.18.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.camel:camel-platform-http-main | 4.14.6 | GHSA-27vm-5vpj-rp5g |
| Maven | org.apache.camel:camel-platform-http-main | 4.18.2 | GHSA-27vm-5vpj-rp5g |
| Maven | org.apache.camel:camel-platform-http-main | 4.20.0 | GHSA-27vm-5vpj-rp5g |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Camel Platform HTTP Main | 4.14.1 – before 4.14.64.18.0 – before 4.18.2 |
Weakness: CWE-288, CWE-551 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
References
- https://camel.apache.org/security/CVE-2026-40022.html vendor-advisory
- http://www.openwall.com/lists/oss-security/2026/04/26/5
- https://access.redhat.com/security/cve/CVE-2026-40022 vdb-entry, x_refsource_REDHAT
- RHBZ#2463178 issue-tracking, x_refsource_REDHAT
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40022.json x_sadp-csaf-vex
- https://access.redhat.com/errata/RHSA-2026:17668 vendor-advisory, x_refsource_REDHAT