Vulnerability · Published Jun 24, 2026 · Assigned by GitHub_M

CVE-2026-39900Cacti: Reflected XSS via tab parameter in auth_profile.php JavaScript context

Medium 5.3

In plain English

A medium-severity cross-site scripting in cacti from Cacti. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.3%top 81.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Cacti is an open source performance and fault management framework. Versions 1.2.30 and prior are vulnerable to Reflected XSS via tab parameter in the auth_profile.php JavaScript context. This issue has been fixed in version 1.2.31.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12cactino fix listedDEBIAN-CVE-2026-39900
Debian:13cactino fix listedDEBIAN-CVE-2026-39900
Debian:14cacti1.2.31+ds1-1DEBIAN-CVE-2026-39900
Ubuntu:24.04:LTScactino fix listedUBUNTU-CVE-2026-39900
Ubuntu:25.10cactino fix listedUBUNTU-CVE-2026-39900
Ubuntu:26.04:LTScactino fix listedUBUNTU-CVE-2026-39900
Ubuntu:26.10cactino fix listedUBUNTU-CVE-2026-39900

Affected products (as reported)

VendorProductVersions
Cacti cacti < 1.2.31

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

References