Vulnerability · Published Apr 8, 2026 · Assigned by GitHub_M

CVE-2026-39892cryptography has a buffer overflow if non-contiguous buffers were passed to APIs

High 7.3

In plain English

A high-severity memory corruption in cryptography from pyca. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.7%top 47.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. From 45.0.0 to before 46.0.7, if a non-contiguous buffer was passed to APIs which accepted Python buffers (e.g. Hash.update()), this could lead to buffer overflows. This vulnerability is fixed in 46.0.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23py3-cryptography46.0.7-r0ALPINE-CVE-2026-39892
Alpine:v3.24py3-cryptography46.0.7-r0ALPINE-CVE-2026-39892
Debian:14python-cryptography46.0.7-1DEBIAN-CVE-2026-39892
PyPIcryptography46.0.7GHSA-p423-j2cm-9vmq
PyPIcryptography46.0.7PYSEC-2026-36

Affected products (as reported)

VendorProductVersions
pyca cryptography >= 45.0.0, < 46.0.7

Weakness: CWE-119, CWE-131 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References