Vulnerability · Published Apr 8, 2026 · Assigned by GitHub_M
CVE-2026-39881Vim Ex command injection in Vims NetBeans integration
Medium 5.0
In plain English
A medium-severity code injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Vim is an open source, command line text editor. Prior to 9.2.0316, a command injection vulnerability in Vim's netbeans interface allows a malicious netbeans server to execute arbitrary Ex commands when Vim connects to it, via unsanitized strings in the defineAnnoType and specialKeys protocol messages. This vulnerability is fixed in 9.2.0316.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | vim | 9.2.0321-r0 | ALPINE-CVE-2026-39881 |
| Alpine:v3.24 | vim | 9.2.0321-r0 | ALPINE-CVE-2026-39881 |
| Debian:12 | vim | no fix listed | DEBIAN-CVE-2026-39881 |
| Debian:13 | vim | 2:9.1.1230-2+deb13u1 | DEBIAN-CVE-2026-39881 |
| Debian:14 | vim | 2:9.2.0338-1 | DEBIAN-CVE-2026-39881 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.28 | UBUNTU-CVE-2026-39881 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.12 | UBUNTU-CVE-2026-39881 |
| Ubuntu:25.10 | vim | 2:9.1.0967-1ubuntu6.3 | UBUNTU-CVE-2026-39881 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.1 | UBUNTU-CVE-2026-39881 |
Affected products (as reported)
Weakness: CWE-94 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:H/A:N
References
- https://github.com/vim/vim/security/advisories/GHSA-mr87-rhgv-7pw6 x_refsource_CONFIRM
- https://github.com/vim/vim/commit/7ab76a86048ed492374ac6b19 x_refsource_MISC
- https://github.com/vim/vim/releases/tag/v9.2.0316 x_refsource_MISC