Vulnerability · Published Apr 21, 2026 · Assigned by GitHub_M

CVE-2026-39386Neko has Self-service Privilege Escalation for Authenticated Users

High 8.8

In plain English

A high-severity improper input validation in neko from m1k1o. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.4%top 61.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Neko is a a self-hosted virtual browser that runs in Docker and uses WebRTC In versions 3.0.0 through 3.0.10 and 3.1.0 through 3.1.1, any authenticated user can immediately obtain full administrative control of the entire Neko instance (member management, room settings, broadcast control, session termination, etc.). This results in a complete compromise of the instance. The vulnerability has been patched in v3.0.11 and v3.1.2. If upgrading is not immediately possible, the following mitigations can reduce risk: Restrict access to trusted users only (avoid granting accounts to untrusted parties); ensure all user passwords are strong and only shared with trusted individuals; run the instance only when needed; avoid leaving it continuously exposed; place the instance behind authentication layers such as a reverse proxy with additional access controls; disable or restrict access to the /api/profile endpoint if feasible; and/or monitor for suspicious privilege changes or unexpected administrative actions. Note that these are temporary mitigations and do not fully eliminate the vulnerability. Upgrading is strongly recommended.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/m1k1o/neko/server3.0.11GHSA-2gw9-c2r2-f5qf
Gogithub.com/m1k1o/neko/server0.0.0-20260406184107-c54bcf1ee211GHSA-2gw9-c2r2-f5qf
Gogithub.com/m1k1o/neko/server0.0.0-20260406184107-c54bcf1ee211GO-2026-4960

Affected products (as reported)

VendorProductVersions
m1k1o neko >= 3.0.0, < 3.0.11>= 3.1.0, < 3.1.2

Weakness: CWE-20, CWE-269, CWE-284, CWE-639, CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References