Vulnerability · Published Apr 7, 2026 · Assigned by GitHub_M
CVE-2026-39381Parse Server's Endpoint `/sessions/me` bypasses `_Session` `protectedFields`
Medium 5.3
In plain English
A medium-severity incorrect authorization in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 10% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.8.0-alpha.7 and 8.6.75, the GET /sessions/me endpoint returns _Session fields that the server operator explicitly configured as protected via the protectedFields server option. Any authenticated user can retrieve their own session's protected fields with a single request. The equivalent GET /sessions and GET /sessions/:objectId endpoints correctly strip protected fields. This vulnerability is fixed in 9.8.0-alpha.7 and 8.6.75.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | parse-server | 9.8.0-alpha.7 | GHSA-g4v2-qx3q-4p64 |
| npm | parse-server | 8.6.75 | GHSA-g4v2-qx3q-4p64 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| parse-community | parse-server | >= 9.0.0, < 9.8.0-alpha.7>= 7.0.0, < 8.6.75 |
Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-g4v2-qx3q-4p64 x_refsource_CONFIRM
- https://github.com/parse-community/parse-server/pull/10406 x_refsource_MISC
- https://github.com/parse-community/parse-server/pull/10407 x_refsource_MISC