Vulnerability · Published Apr 7, 2026 · Assigned by GitHub_M
CVE-2026-39380Open Source Point of Sale has Stored XSS in Stock Location (Configuration)
Medium 5.4
In plain English
A medium-severity cross-site scripting in opensourcepos from opensourcepos. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities).
Official description
Open Source Point of Sale is a web based point-of-sale application written in PHP using CodeIgniter framework. Prior to 3.4.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Stock Locations configuration feature. The application fails to properly sanitize user input supplied through the stock_location parameter, allowing attackers to inject malicious JavaScript code that is stored in the database and executed when rendered in the Employees interface. This vulnerability is fixed in 3.4.3.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| opensourcepos | opensourcepos | < 3.4.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N