Vulnerability · Published Apr 10, 2026 · Assigned by apache

CVE-2026-39304Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incorrect handling of TLSv1.3 KeyUpdate can be exploited to cause DoS via OOM

High 7.5

In plain English

A high-severity uncontrolled resource consumption in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 60% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.9%top 40.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ. ActiveMQ NIO SSL transports do not correctly handle TLSv1.3 handshake KeyUpdates triggered by clients. This makes it possible for a client to rapidly trigger updates which causes the broker to exhaust all its memory in the SSL engine leading to DoS. Note: TLS versions before TLSv1.3 (such as TLSv1.2) are broken but are not vulnerable to OOM. Previous TLS versions require a full handshake renegotiation which causes a connection to hang but not OOM. This is fixed as well. This issue affects Apache ActiveMQ Client: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or 5.19.5, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2026-39304
Debian:13activemqno fix listedDEBIAN-CVE-2026-39304
Mavenorg.apache.activemq:activemq-all5.19.4GHSA-5568-6qcg-g7fx
Mavenorg.apache.activemq:activemq-all6.2.4GHSA-5568-6qcg-g7fx
Mavenorg.apache.activemq:activemq-broker5.19.4GHSA-5568-6qcg-g7fx
Mavenorg.apache.activemq:activemq-broker6.2.4GHSA-5568-6qcg-g7fx
Mavenorg.apache.activemq:activemq-client5.19.4GHSA-5568-6qcg-g7fx
Mavenorg.apache.activemq:activemq-client6.2.4GHSA-5568-6qcg-g7fx
Mavenorg.apache.activemq:apache-activemq6.2.4GHSA-5568-6qcg-g7fx
Mavenorg.apache.activemq:apache-activemq5.19.4GHSA-5568-6qcg-g7fx
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2026-39304
Ubuntu:25.10activemqno fix listedUBUNTU-CVE-2026-39304
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2026-39304
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2026-39304

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ Client 0 – before 5.19.46.0.0 – before 6.2.4
Apache Software Foundation Apache ActiveMQ Broker 0 – before 5.19.46.0.0 – before 6.2.4
Apache Software Foundation Apache ActiveMQ All 0 – before 5.19.46.0.0 – before 6.2.4
Apache Software Foundation Apache ActiveMQ 0 – before 5.19.46.0.0 – before 6.2.4

Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References