Vulnerability · Published Apr 7, 2026 · Assigned by GitHub_M

CVE-2026-35611Addressable has a Regular Expression Denial of Service in Addressable templates

High 7.5

In plain English

A high-severity regular-expression denial of service in addressable from sporkmonger. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 68.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Addressable is an alternative implementation to the URI implementation that is part of Ruby's standard library. From 2.3.0 to before 2.9.0, within the URI template implementation in Addressable, two classes of URI template generate regular expressions vulnerable to catastrophic backtracking. Templates using the * (explode) modifier with any expansion operator (e.g., {foo*}, {+var*}, {#var*}, {/var*}, {.var*}, {;var*}, {?var*}, {&var*}) generate patterns with nested unbounded quantifiers that are O(2^n) when matched against a maliciously crafted URI. Templates using multiple variables with the + or # operators (e.g., {+v1,v2,v3}) generate patterns with O(n^k) complexity due to the comma separator being within the matched character class, causing ambiguous backtracking across k variables. When matched against a maliciously crafted URI, this can result in catastrophic backtracking and uncontrolled resource consumption, leading to denial of service. This vulnerability is fixed in 2.9.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23ruby-addressable2.9.0-r0ALPINE-CVE-2026-35611
Alpine:v3.24ruby-addressable2.9.0-r0ALPINE-CVE-2026-35611
Debian:12ruby-addressableno fix listedDEBIAN-CVE-2026-35611
Debian:13ruby-addressableno fix listedDEBIAN-CVE-2026-35611
Debian:14ruby-addressable2.9.0-1DEBIAN-CVE-2026-35611
RubyGemsaddressable2.9.0GHSA-h27x-rffw-24p4
Ubuntu:25.10ruby-addressableno fix listedUBUNTU-CVE-2026-35611
Ubuntu:26.10ruby-addressableno fix listedUBUNTU-CVE-2026-35611

Affected products (as reported)

VendorProductVersions
sporkmonger addressable >= 2.3.0, < 2.9.0

Weakness: CWE-1333 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References