Vulnerability · Published Apr 17, 2026 · Assigned by GitHub_M
CVE-2026-35215Firebird: DoS via malicious slice descriptor in slice packet
High 7.5
In plain English
A high-severity security flaw in firebird from FirebirdSQL. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, the sdl_desc() function does not validate the length of a decoded SDL descriptor from a slice packet. A zero-length descriptor is later used to calculate the number of slice items, causing a division by zero. An unauthenticated attacker can exploit this by sending a crafted slice packet to crash the server. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | firebird3.0 | no fix listed | DEBIAN-CVE-2026-35215 |
| Debian:13 | firebird3.0 | no fix listed | DEBIAN-CVE-2026-35215 |
| Debian:14 | firebird3.0 | 3.0.14.ds7-1 | DEBIAN-CVE-2026-35215 |
| Debian:13 | firebird4.0 | no fix listed | DEBIAN-CVE-2026-35215 |
| Debian:14 | firebird4.0 | 4.0.7.3271.ds6-1 | DEBIAN-CVE-2026-35215 |
| Ubuntu:22.04:LTS | firebird3.0 | no fix listed | UBUNTU-CVE-2026-35215 |
| Ubuntu:24.04:LTS | firebird3.0 | no fix listed | UBUNTU-CVE-2026-35215 |
| Ubuntu:25.10 | firebird3.0 | no fix listed | UBUNTU-CVE-2026-35215 |
| Ubuntu:26.04:LTS | firebird3.0 | no fix listed | UBUNTU-CVE-2026-35215 |
| Ubuntu:26.10 | firebird3.0 | no fix listed | UBUNTU-CVE-2026-35215 |
| Ubuntu:25.10 | firebird4.0 | no fix listed | UBUNTU-CVE-2026-35215 |
| Ubuntu:26.04:LTS | firebird4.0 | no fix listed | UBUNTU-CVE-2026-35215 |
| Ubuntu:26.10 | firebird4.0 | no fix listed | UBUNTU-CVE-2026-35215 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| FirebirdSQL | firebird | >= 3.0.0, < 3.0.14>= 4.0.0, < 4.0.7>= 5.0.0, < 5.0.4 |
Weakness: CWE-369 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/FirebirdSQL/firebird/security/advisories/GHSA-g99w-prq5-29c6 x_refsource_CONFIRM
- https://github.com/FirebirdSQL/firebird/releases/tag/v3.0.14 x_refsource_MISC
- https://github.com/FirebirdSQL/firebird/releases/tag/v4.0.7 x_refsource_MISC
- https://github.com/FirebirdSQL/firebird/releases/tag/v5.0.4 x_refsource_MISC