Vulnerability · Published Apr 6, 2026 · Assigned by GitHub_M
CVE-2026-35177Path traversal issue with zip.vim in Vim
Medium 4.1
In plain English
A medium-severity path traversal in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)4.1Medium
Exploit odds (30 days)0.1%top 97.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Vim is an open source, command line text editor. Prior to 9.2.0280, a path traversal bypass in Vim's zip.vim plugin allows overwriting of arbitrary files when opening specially crafted zip archives, circumventing the previous fix for CVE-2025-53906. This vulnerability is fixed in 9.2.0280.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:10 | vim-X11 | 2:9.1.083-9.el10_2.3 | ALSA-2026:22711 |
| AlmaLinux:8 | vim-X11 | 2:8.0.1763-23.el8_10 | ALSA-2026:22730 |
| AlmaLinux:9 | vim-X11 | 2:8.2.2637-26.el9_8.5 | ALSA-2026:22717 |
| AlmaLinux:10 | vim-common | 2:9.1.083-9.el10_2.3 | ALSA-2026:22711 |
| AlmaLinux:8 | vim-common | 2:8.0.1763-23.el8_10 | ALSA-2026:22730 |
| AlmaLinux:9 | vim-common | 2:8.2.2637-26.el9_8.5 | ALSA-2026:22717 |
| AlmaLinux:10 | vim-data | 2:9.1.083-9.el10_2.3 | ALSA-2026:22711 |
| AlmaLinux:10 | vim-enhanced | 2:9.1.083-9.el10_2.3 | ALSA-2026:22711 |
| AlmaLinux:8 | vim-enhanced | 2:8.0.1763-23.el8_10 | ALSA-2026:22730 |
| AlmaLinux:9 | vim-enhanced | 2:8.2.2637-26.el9_8.5 | ALSA-2026:22717 |
| AlmaLinux:10 | vim-filesystem | 2:9.1.083-9.el10_2.3 | ALSA-2026:22711 |
| AlmaLinux:8 | vim-filesystem | 2:8.0.1763-23.el8_10 | ALSA-2026:22730 |
| AlmaLinux:9 | vim-filesystem | 2:8.2.2637-26.el9_8.5 | ALSA-2026:22717 |
| AlmaLinux:10 | vim-minimal | 2:9.1.083-9.el10_2.3 | ALSA-2026:22711 |
| AlmaLinux:8 | vim-minimal | 2:8.0.1763-23.el8_10 | ALSA-2026:22730 |
| AlmaLinux:9 | vim-minimal | 2:8.2.2637-26.el9_8.5 | ALSA-2026:22717 |
| AlmaLinux:10 | xxd | 2:9.1.083-9.el10_2.3 | ALSA-2026:22711 |
| Alpine:v3.23 | vim | 9.2.0280-r0 | ALPINE-CVE-2026-35177 |
| Alpine:v3.24 | vim | 9.2.0280-r0 | ALPINE-CVE-2026-35177 |
| Debian:12 | vim | no fix listed | DEBIAN-CVE-2026-35177 |
| Debian:13 | vim | 2:9.1.1230-2+deb13u1 | DEBIAN-CVE-2026-35177 |
| Debian:14 | vim | 2:9.2.0315-1 | DEBIAN-CVE-2026-35177 |
| Rocky Linux:10 | vim | 2:9.1.083-9.el10_2.3 | RLSA-2026:22711 |
| Rocky Linux:8 | vim | 2:8.0.1763-23.el8_10 | RLSA-2026:22730 |
| Rocky Linux:9 | vim | 2:8.2.2637-26.el9_8.5 | RLSA-2026:22717 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.33 | USN-8500-1 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.33 | UBUNTU-CVE-2026-35177 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.17 | USN-8500-1 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.12 | UBUNTU-CVE-2026-35177 |
| Ubuntu:25.10 | vim | 2:9.1.0967-1ubuntu6.3 | UBUNTU-CVE-2026-35177 |
| Ubuntu:25.10 | vim | 2:9.1.0967-1ubuntu6.8 | USN-8500-1 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.1 | UBUNTU-CVE-2026-35177 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.6 | USN-8500-1 |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:L
References
- https://github.com/vim/vim/security/advisories/GHSA-jc86-w7vm-8p24 x_refsource_CONFIRM