Vulnerability · Published Apr 2, 2026 · Assigned by GitHub_M

CVE-2026-34829Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length

High 7.5

In plain English

A high-severity uncontrolled resource consumption in rack from rack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 68.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Multipart::Parser only wraps the request body in a BoundedIO when CONTENT_LENGTH is present. When a multipart/form-data request is sent without a Content-Length header, such as with HTTP chunked transfer encoding, multipart parsing continues until end-of-stream with no total size limit. For file parts, the uploaded body is written directly to a temporary file on disk rather than being constrained by the buffered in-memory upload limit. An unauthenticated attacker can therefore stream an arbitrarily large multipart file upload and consume unbounded disk space. This results in a denial of service condition for Rack applications that accept multipart form data. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-rack2.2.22-0+deb12u2DEBIAN-CVE-2026-34829
Debian:13ruby-rack3.1.20-0+deb13u2DEBIAN-CVE-2026-34829
Debian:14ruby-rack3.2.6-2DEBIAN-CVE-2026-34829
RubyGemsrack2.2.23GHSA-8vqr-qjwx-82mw
RubyGemsrack3.1.21GHSA-8vqr-qjwx-82mw
RubyGemsrack3.2.6GHSA-8vqr-qjwx-82mw
Ubuntu:24.04:LTSruby-rack2.2.7-1ubuntu0.7UBUNTU-CVE-2026-34829
Ubuntu:25.10ruby-rack3.1.16-0.1ubuntu0.3UBUNTU-CVE-2026-34829
Ubuntu:26.04:LTSruby-rack3.2.4-1ubuntu1.1UBUNTU-CVE-2026-34829
Ubuntu:26.04:LTSruby-rack3.2.4-1ubuntu1.1USN-8989-1

Affected products (as reported)

VendorProductVersions
rack rack < 2.2.23>= 3.0.0.beta1, < 3.1.21>= 3.2.0, < 3.2.6

Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References