Vulnerability · Published Apr 2, 2026 · Assigned by GitHub_M

CVE-2026-34743XZ Utils: Buffer overflow in lzma_index_append()

Low 1.7

In plain English

A low-severity heap buffer overflow in xz from tukaani-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)1.7Low
Exploit odds (30 days)0.5%top 54.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

XZ Utils provide a general-purpose data-compression library plus command-line tools. Prior to version 5.8.3, if lzma_index_decoder() was used to decode an Index that contained no Records, the resulting lzma_index was left in a state where where a subsequent lzma_index_append() would allocate too little memory, and a buffer overflow would occur. This issue has been patched in version 5.8.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10xz1:5.6.2-4.el10_2.1ALSA-2026:64787
AlmaLinux:9xz5.2.5-8.el9_8.1ALSA-2026:89749
AlmaLinux:10xz-devel1:5.6.2-4.el10_2.1ALSA-2026:64787
AlmaLinux:9xz-devel5.2.5-8.el9_8.1ALSA-2026:89749
AlmaLinux:10xz-libs1:5.6.2-4.el10_2.1ALSA-2026:64787
AlmaLinux:9xz-libs5.2.5-8.el9_8.1ALSA-2026:89749
AlmaLinux:10xz-lzma-compat1:5.6.2-4.el10_2.1ALSA-2026:64787
AlmaLinux:9xz-lzma-compat5.2.5-8.el9_8.1ALSA-2026:89749
Alpine:v3.20xz5.8.3-r0ALPINE-CVE-2026-34743
Alpine:v3.21xz5.8.3-r0ALPINE-CVE-2026-34743
Alpine:v3.22xz5.8.3-r0ALPINE-CVE-2026-34743
Alpine:v3.23xz5.8.3-r0ALPINE-CVE-2026-34743
Alpine:v3.24xz5.8.3-r0ALPINE-CVE-2026-34743
Debian:12xz-utils5.4.1-1+deb12u1DEBIAN-CVE-2026-34743
Debian:13xz-utils5.8.1-1+deb13u1DEBIAN-CVE-2026-34743
Debian:14xz-utils5.8.3-1DEBIAN-CVE-2026-34743
Rocky Linux:10xz1:5.6.2-4.el10_2.1RLSA-2026:64787
Rocky Linux:9xz0:5.2.5-8.el9_8.1RLSA-2026:89749
Ubuntu:22.04:LTSxz-utils5.2.5-2ubuntu1.1USN-8362-1
Ubuntu:22.04:LTSxz-utils5.2.5-2ubuntu1.1UBUNTU-CVE-2026-34743
Ubuntu:24.04:LTSxz-utils5.6.1+really5.4.5-1ubuntu0.3USN-8362-1
Ubuntu:24.04:LTSxz-utils5.6.1+really5.4.5-1ubuntu0.3UBUNTU-CVE-2026-34743
Ubuntu:25.10xz-utils5.8.1-1ubuntu0.1UBUNTU-CVE-2026-34743
Ubuntu:25.10xz-utils5.8.1-1ubuntu0.1USN-8362-1

Affected products (as reported)

VendorProductVersions
tukaani-project xz < 5.8.3

Weakness: CWE-122 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U

References