Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M

CVE-2026-34595Parse Server: LiveQuery protected-field guard bypass via array-like logical operator value

Medium 5.3

In plain English

A medium-severity type confusion in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.3%top 82.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.70 and 9.7.0-alpha.18, an authenticated user with find class-level permission can bypass the protectedFields class-level permission setting on LiveQuery subscriptions. By sending a subscription with a $or, $and, or $nor operator value as a plain object with numeric keys and a length property (an "array-like" object) instead of an array, the protected-field guard is bypassed. The subscription event firing acts as a binary oracle, allowing the attacker to infer whether a protected field matches a given test value. This issue has been patched in versions 8.6.70 and 9.7.0-alpha.18.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.7.0-alpha.16GHSA-mmg8-87c5-jrc2
npmparse-server8.6.70GHSA-mmg8-87c5-jrc2

Affected products (as reported)

VendorProductVersions
parse-community parse-server < 8.6.70>= 9.0.0, < 9.7.0-alpha.18

Weakness: CWE-843 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

References