Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M

CVE-2026-34574Parse Server: Session field immutability bypass via falsy-value guard

Medium 5.3

In plain English

A medium-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.2%top 87.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.69 and 9.7.0-alpha.14, an authenticated user can bypass the immutability guard on session fields (expiresAt, createdWith) by sending a null value in a PUT request to the session update endpoint. This allows nullifying the session expiry, making the session valid indefinitely and bypassing configured session length policies. This issue has been patched in versions 8.6.69 and 9.7.0-alpha.14.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.7.0-alpha.14GHSA-f6j3-w9v3-cq22
npmparse-server8.6.69GHSA-f6j3-w9v3-cq22

Affected products (as reported)

VendorProductVersions
parse-community parse-server < 8.6.69>= 9.0.0, < 9.7.0-alpha.14

Weakness: CWE-697 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

References