Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M

CVE-2026-34573Parse Server: GraphQL complexity validator exponential fragment traversal DoS

High 8.2

In plain English

A high-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.2High
Exploit odds (30 days)0.6%top 49.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.68 and 9.7.0-alpha.12, the GraphQL query complexity validator can be exploited to cause a denial-of-service by sending a crafted query with binary fan-out fragment spreads. A single unauthenticated request can block the Node.js event loop for seconds, denying service to all concurrent users. This only affects deployments that have enabled the requestComplexity.graphQLDepth or requestComplexity.graphQLFields configuration options. This issue has been patched in versions 8.6.68 and 9.7.0-alpha.12.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.7.0-alpha.12GHSA-mfj6-6p54-m98c
npmparse-server8.6.68GHSA-mfj6-6p54-m98c

Affected products (as reported)

VendorProductVersions
parse-community parse-server < 8.6.68>= 9.0.0, < 9.7.0-alpha.12

Weakness: CWE-407 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References