Vulnerability · Published Apr 1, 2026 · Assigned by GitHub_M
CVE-2026-34571CI4MS: Stored Cross‑Site Scripting (Stored XSS) in Backend User Management Allows Session Hijacking and Full Administrative Account Compromise
Critical 10.0
In plain English
A critical-severity cross-site scripting in ci4ms from ci4-cms-erp. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.0.0, a Stored Cross-Site Scripting (Stored XSS) vulnerability exists in the backend user management functionality. The application fails to properly sanitize user-controlled input before rendering it in the administrative interface, allowing attackers to inject persistent JavaScript code. This results in automatic execution whenever backend users access the affected page, enabling session hijacking, privilege escalation, and full administrative account compromise. This issue has been patched in version 0.31.0.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | ci4-cms-erp/ci4ms | 0.31.0.0 | GHSA-fc4p-p49v-r948 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| ci4-cms-erp | ci4ms | < 0.31.0.0 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-fc4p-p49v-r948 x_refsource_CONFIRM
- https://github.com/ci4-cms-erp/ci4ms/releases/tag/0.31.0.0 x_refsource_MISC