Vulnerability · Published Apr 2, 2026 · Assigned by GitHub_M
CVE-2026-34522SillyTavern: Path traversal in `/api/chats/import` allows arbitrary file write outside intended chat directory
High 8.1
In plain English
A high-severity path traversal in SillyTavern from SillyTavern. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to version 1.17.0, a path traversal vulnerability in /api/chats/import allows an authenticated attacker to write attacker-controlled files outside the intended chats directory by injecting traversal sequences into character_name. This issue has been patched in version 1.17.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | sillytavern | 1.17.0 | GHSA-xvww-xhx6-22pf |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| SillyTavern | SillyTavern | < 1.17.0 |
Weakness: CWE-22, CWE-73 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
References
- https://github.com/SillyTavern/SillyTavern/security/advisories/GHSA-xvww-xhx6-22pf x_refsource_CONFIRM
- https://github.com/SillyTavern/SillyTavern/releases/tag/1.17.0 x_refsource_MISC