Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M

CVE-2026-34400alerta-server has potential SQL Injection vulnerability in Query String Syntax (q=) API

Critical 9.8

In plain English

A critical-severity SQL injection in alerta from alerta. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)0.5%top 55.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Alerta is a monitoring tool. Prior to version 9.1.0, the Query string search API (q=) was vulnerable to SQL injection via the Postgres query parser, which built WHERE clauses by interpolating user-supplied search terms directly into SQL strings via f-strings. This issue has been patched in version 9.1.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIalerta-server9.1.0GHSA-8prr-286p-4w7j
PyPIalerta-server9.1.0PYSEC-2026-2341

Affected products (as reported)

VendorProductVersions
alerta alerta < 9.1.0

Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References