Vulnerability · Published Apr 15, 2026 · Assigned by GitHub_M
CVE-2026-34393Weblate: Privilege escalation in the user API endpoint
High 8.8
In plain English
A high-severity privilege mismanagement in weblate from WeblateOrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.4%top 66.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Weblate is a web based localization tool. In versions prior to 5.17, the user patching API endpoint didn't properly limit the scope of edits. This issue has been fixed in version 5.17.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | weblate | 5.17 | GHSA-3382-gw9x-477v |
| PyPI | weblate | 5.17 | PYSEC-2026-155 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| WeblateOrg | weblate | < 5.17 |
Weakness: CWE-269 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-3382-gw9x-477v x_refsource_CONFIRM
- https://github.com/WeblateOrg/weblate/pull/18687 x_refsource_MISC