Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M

CVE-2026-34373Parse Server: GraphQL API endpoint ignores CORS origin restriction

Medium 5.3

In plain English

A medium-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.2%top 89.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.66 and 9.7.0-alpha.10, the GraphQL API endpoint does not respect the allowOrigin server option and unconditionally allows cross-origin requests from any website. This bypasses origin restrictions that operators configure to control which websites can interact with the Parse Server API. The REST API correctly enforces the configured allowOrigin restriction. This issue has been patched in versions 8.6.66 and 9.7.0-alpha.10.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.7.0-alpha.10GHSA-q3p6-g7c4-829c
npmparse-server8.6.66GHSA-q3p6-g7c4-829c

Affected products (as reported)

VendorProductVersions
parse-community parse-server < 8.6.66>= 9.0.0, < 9.7.0-alpha.10

Weakness: CWE-346 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N

References