Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M

CVE-2026-34224Parse Server: MFA single-use token bypass via concurrent authData login requests

Medium 4.4

In plain English

A medium-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.4Medium
Exploit odds (30 days)0.3%top 75.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.64 and 9.7.0-alpha.8, an attacker who possesses a valid authentication provider token and a single MFA recovery code or SMS one-time password can create multiple authenticated sessions by sending concurrent login requests via the authData login endpoint. This defeats the single-use guarantee of MFA recovery codes and SMS one-time passwords, allowing session persistence even after the legitimate user revokes detected sessions. This issue has been patched in versions 8.6.64 and 9.7.0-alpha.8.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmparse-server9.7.0-alpha.8GHSA-w73w-g5xw-rwhf
npmparse-server8.6.64GHSA-w73w-g5xw-rwhf

Affected products (as reported)

VendorProductVersions
parse-community parse-server < 8.6.64>= 9.0.0, < 9.7.0-alpha.8

Weakness: CWE-367 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:N

References