Actively exploited · Published Apr 7, 2026 · Assigned by apache

CVE-2026-34197Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans

High 8.8 Exploited

In plain English

A high-severity improper input validation in Apache ActiveMQ from Apache Software Foundation. Attackers are actively exploiting it in the wild (listed by CISA on April 16, 2026). The chance it is exploited in the next 30 days is estimated at 98.3% (higher than 99.9% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)98.3%top 0.1% of all CVEs
Exploited in the wildYesCISA KEV since Apr 16, 2026
Attack tooling3Metasploit, Nuclei, Public PoC

CISA guidance

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Federal agencies must remediate by Apr 30, 2026.

Official description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12activemqno fix listedDEBIAN-CVE-2026-34197
Debian:13activemqno fix listedDEBIAN-CVE-2026-34197
Mavenorg.apache.activemq:activemq-all5.19.5GHSA-rxpj-7qvf-xv32
Mavenorg.apache.activemq:activemq-all6.2.3GHSA-rxpj-7qvf-xv32
Mavenorg.apache.activemq:activemq-broker5.19.5GHSA-rxpj-7qvf-xv32
Mavenorg.apache.activemq:activemq-broker6.2.3GHSA-rxpj-7qvf-xv32
Ubuntu:24.04:LTSactivemqno fix listedUBUNTU-CVE-2026-34197
Ubuntu:25.10activemqno fix listedUBUNTU-CVE-2026-34197
Ubuntu:26.04:LTSactivemqno fix listedUBUNTU-CVE-2026-34197
Ubuntu:26.10activemqno fix listedUBUNTU-CVE-2026-34197

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache ActiveMQ Broker 0 – before 5.19.46.0.0 – before 6.2.3
Apache Software Foundation Apache ActiveMQ All 0 – before 5.19.46.0.0 – before 6.2.3
Apache Software Foundation Apache ActiveMQ 0 – before 5.19.46.0.0 – before 6.2.3

Weakness: CWE-20, CWE-94, CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References