Vulnerability · Published Apr 7, 2026 · Assigned by GitHub_M

CVE-2026-34079Flatpak affected by arbitrary file deletion on the host filesystem

High 7.5

In plain English

A high-severity path traversal in flatpak from flatpak. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.3%top 73.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Flatpak is a Linux application sandboxing and distribution framework. Prior to 1.16.4, the caching for ld.so removes outdated cache files without properly checking that the app controlled path to the outdated cache is in the cache directory. This allows Flatpak apps to delete arbitrary files on the host. This vulnerability is fixed in 1.16.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10flatpak1.16.0-9.el10_2.1ALSA-2026:21757
AlmaLinux:8flatpak1.12.9-4.el8_10ALSA-2026:21756
AlmaLinux:9flatpak1.12.9-4.el9_8.1ALSA-2026:21755
AlmaLinux:10flatpak-devel1.16.0-9.el10_2.1ALSA-2026:21757
AlmaLinux:8flatpak-devel1.12.9-4.el8_10ALSA-2026:21756
AlmaLinux:9flatpak-devel1.12.9-4.el9_8.1ALSA-2026:21755
AlmaLinux:10flatpak-libs1.16.0-9.el10_2.1ALSA-2026:21757
AlmaLinux:8flatpak-libs1.12.9-4.el8_10ALSA-2026:21756
AlmaLinux:9flatpak-libs1.12.9-4.el9_8.1ALSA-2026:21755
AlmaLinux:10flatpak-selinux1.16.0-9.el10_2.1ALSA-2026:21757
AlmaLinux:8flatpak-selinux1.12.9-4.el8_10ALSA-2026:21756
AlmaLinux:9flatpak-selinux1.12.9-4.el9_8.1ALSA-2026:21755
AlmaLinux:10flatpak-session-helper1.16.0-9.el10_2.1ALSA-2026:21757
AlmaLinux:8flatpak-session-helper1.12.9-4.el8_10ALSA-2026:21756
AlmaLinux:9flatpak-session-helper1.12.9-4.el9_8.1ALSA-2026:21755
Alpine:v3.23flatpak1.16.4-r0ALPINE-CVE-2026-34079
Alpine:v3.24flatpak1.16.4-r0ALPINE-CVE-2026-34079
Debian:12flatpak1.14.10-1~deb12u2DEBIAN-CVE-2026-34079
Debian:13flatpak1.16.6-1~deb13u1DEBIAN-CVE-2026-34079
Debian:14flatpak1.16.4-1DEBIAN-CVE-2026-34079
Rocky Linux:10flatpak0:1.16.0-9.el10_2.1RLSA-2026:21757
Rocky Linux:8flatpak0:1.12.9-4.el8_10RLSA-2026:21756
Rocky Linux:9flatpak0:1.12.9-4.el9_8.1RLSA-2026:21755
Ubuntu:25.10flatpakno fix listedUBUNTU-CVE-2026-34079

Affected products (as reported)

VendorProductVersions
flatpak flatpak < 1.16.4

Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References