Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M
CVE-2026-34060Ruby LSP has arbitrary code execution through branch setting
Critical 9.8
In plain English
A critical-severity code injection in ruby-lsp from Shopify. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | ruby-ruby-lsp | 0.26.9-0.1 | DEBIAN-CVE-2026-34060 |
| RubyGems | ruby-lsp | 0.26.9 | GHSA-c4r5-fxqw-vh93 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Shopify | ruby-lsp | < 0.26.9 |
| Shopify | Shopify.ruby-lsp | < 0.10.2 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/Shopify/ruby-lsp/security/advisories/GHSA-c4r5-fxqw-vh93 x_refsource_CONFIRM
- https://github.com/Shopify/ruby-lsp/releases/tag/v0.26.9 x_refsource_MISC