Vulnerability · Published May 4, 2026 · Assigned by apache

CVE-2026-34059Apache HTTP Server: mod_proxy_ajp: Heap Over-Read and memory disclosure in ajp_parse_data()

High 7.5

In plain English

A high-severity security flaw in Apache HTTP Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 66.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Buffer Over-read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10httpd2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:8httpd2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:9httpd2.4.62-13.el9_8.1ALSA-2026:21391
AlmaLinux:10httpd-core2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:9httpd-core2.4.62-13.el9_8.1ALSA-2026:21391
AlmaLinux:10httpd-devel2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:8httpd-devel2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:9httpd-devel2.4.62-13.el9_8.1ALSA-2026:21391
AlmaLinux:10httpd-filesystem2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:8httpd-filesystem2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:9httpd-filesystem2.4.62-13.el9_8.1ALSA-2026:21391
AlmaLinux:10httpd-manual2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:8httpd-manual2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:9httpd-manual2.4.62-13.el9_8.1ALSA-2026:21391
AlmaLinux:10httpd-tools2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:8httpd-tools2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:9httpd-tools2.4.62-13.el9_8.1ALSA-2026:21391
AlmaLinux:8mod_http21.15.7-10.module_el8.10.0+4185+0955a0d7.5ALSA-2026:22140
AlmaLinux:10mod_ldap2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:8mod_ldap2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:9mod_ldap2.4.62-13.el9_8.1ALSA-2026:21391
AlmaLinux:10mod_lua2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:9mod_lua2.4.62-13.el9_8.1ALSA-2026:21391
AlmaLinux:8mod_md1:2.0.8-8.module_el8.10.0+4088+57f011c1.2ALSA-2026:22140
AlmaLinux:10mod_proxy_html1:2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:8mod_proxy_html1:2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:9mod_proxy_html1:2.4.62-13.el9_8.1ALSA-2026:21391
AlmaLinux:10mod_session2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:8mod_session2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:9mod_session2.4.62-13.el9_8.1ALSA-2026:21391
AlmaLinux:10mod_ssl1:2.4.63-13.el10_2.1ALSA-2026:21433
AlmaLinux:8mod_ssl1:2.4.37-65.module_el8.10.0+4185+0955a0d7.8ALSA-2026:22140
AlmaLinux:9mod_ssl1:2.4.62-13.el9_8.1ALSA-2026:21391
Alpine:v3.20apache22.4.67-r0ALPINE-CVE-2026-34059
Alpine:v3.21apache22.4.67-r0ALPINE-CVE-2026-34059
Alpine:v3.22apache22.4.67-r0ALPINE-CVE-2026-34059
Alpine:v3.23apache22.4.67-r0ALPINE-CVE-2026-34059
Alpine:v3.24apache22.4.67-r0ALPINE-CVE-2026-34059
Debian:12apache22.4.67-1~deb12u2DEBIAN-CVE-2026-34059
Debian:13apache22.4.67-1~deb13u2DEBIAN-CVE-2026-34059
Debian:14apache22.4.67-1DEBIAN-CVE-2026-34059
Rocky Linux:10httpd0:2.4.63-13.el10_2.1RLSA-2026:21433
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1830+22f0c9e0RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+2061+8d03fdec.5RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+40053+5a18018e.7RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1840+b070a976.1RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1842+4a9649e8.2RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+40045+6ce8579b.6RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1984+1bed3124.4RLSA-2026:22140
Rocky Linux:8httpd0:2.4.37-65.module+el8.10.0+1938+3b7755d4.3RLSA-2026:22140
Rocky Linux:9httpd0:2.4.62-13.el9_8.1RLSA-2026:21391
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1883+38ed6c58.1RLSA-2026:22140
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1775+6b057638RLSA-2026:22140
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1830+22f0c9e0RLSA-2026:22140
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+1938+3b7755d4.3RLSA-2026:22140
Rocky Linux:8mod_http20:1.15.7-10.module+el8.10.0+2061+8d03fdec.4RLSA-2026:22140
Rocky Linux:8mod_md1:2.0.8-8.module+el8.10.0+40053+5a18018e.2RLSA-2026:22140
Rocky Linux:8mod_md1:2.0.8-8.module+el8.9.0+1370+89cc8ad5RLSA-2026:22140
Ubuntu:22.04:LTSapache22.4.52-1ubuntu4.20UBUNTU-CVE-2026-34059
Ubuntu:24.04:LTSapache22.4.58-1ubuntu8.12UBUNTU-CVE-2026-34059
Ubuntu:25.10apache22.4.64-1ubuntu3.4UBUNTU-CVE-2026-34059
Ubuntu:26.04:LTSapache22.4.66-2ubuntu2.1UBUNTU-CVE-2026-34059

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache HTTP Server 0 – through 2.4.66

Weakness: CWE-126 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References