Vulnerability · Published Apr 3, 2026 · Assigned by GitHub_M
CVE-2026-34052LTI JupyterHub Authenticator: Unbounded Memory Growth via Nonce Storage (Denial of Service)
Medium 5.9
In plain English
A medium-severity memory leak in ltiauthenticator from jupyterhub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | jupyterhub-ltiauthenticator | 1.6.3 | GHSA-8mxq-7xr7-2fxj |
| PyPI | jupyterhub-ltiauthenticator | 1.6.3 | PYSEC-2026-2533 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jupyterhub | ltiauthenticator | < 1.6.3 |
Weakness: CWE-401, CWE-770 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H