Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M
CVE-2026-34040Moby: AuthZ plugin bypass with oversized request body
High 8.8
In plain English
A high-severity authentication bypass in moby from moby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 9.3% (higher than 95% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.8High
Exploit odds (30 days)9.3%top 4.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC
Official description
Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows attackers to bypass authorization plugins (AuthZ). This issue has been patched in version 29.3.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | docker | 29.3.1-r0 | ALPINE-CVE-2026-34040 |
| Alpine:v3.24 | docker | 29.3.1-r0 | ALPINE-CVE-2026-34040 |
| Debian:12 | docker.io | no fix listed | DEBIAN-CVE-2026-34040 |
| Debian:13 | docker.io | 26.1.5+dfsg1-9+deb13u1 | DEBIAN-CVE-2026-34040 |
| Debian:14 | docker.io | 28.5.2+dfsg4-2 | DEBIAN-CVE-2026-34040 |
| Go | github.com/docker/docker | no fix listed | GO-2026-4887 |
| Go | github.com/moby/moby | no fix listed | GO-2026-4887 |
| Go | github.com/moby/moby | 29.3.1 | GHSA-x744-4wpc-v9h2 |
| Go | github.com/moby/moby/v2 | 2.0.0-beta.8 | GO-2026-4887 |
| Go | github.com/moby/moby/v2 | 2.0.0-beta.8 | GHSA-x744-4wpc-v9h2 |
| Ubuntu:25.10 | docker.io | no fix listed | UBUNTU-CVE-2026-34040 |
| Ubuntu:26.04:LTS | docker.io | no fix listed | UBUNTU-CVE-2026-34040 |
| Ubuntu:26.10 | docker.io | no fix listed | UBUNTU-CVE-2026-34040 |
| Ubuntu:25.10 | docker.io-app | no fix listed | UBUNTU-CVE-2026-34040 |
| Ubuntu:26.04:LTS | docker.io-app | no fix listed | UBUNTU-CVE-2026-34040 |
| Ubuntu:26.10 | docker.io-app | no fix listed | UBUNTU-CVE-2026-34040 |
Affected products (as reported)
Weakness: CWE-288 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
References
- https://github.com/moby/moby/security/advisories/GHSA-x744-4wpc-v9h2 x_refsource_CONFIRM
- https://github.com/moby/moby/releases/tag/docker-v29.3.1 x_refsource_MISC