Vulnerability · Published Mar 31, 2026 · Assigned by GitHub_M

CVE-2026-33762go-git: Missing validation decoding Index v4 files leads to panic

Low 2.8

In plain English

A low-severity security flaw in go-git from go-git. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.8Low
Exploit odds (30 days)0.2%top 92.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

go-git is an extensible git implementation library written in pure Go. Prior to version 5.17.1, go-git’s index decoder for format version 4 fails to validate the path name prefix length before applying it to the previously decoded path name. A maliciously crafted index file can trigger an out-of-bounds slice operation, resulting in a runtime panic during normal index parsing. This issue only affects Git index format version 4. Earlier formats (go-git supports only v2 and v3) are not vulnerable to this issue. This issue has been patched in version 5.17.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12golang-github-go-git-go-gitno fix listedDEBIAN-CVE-2026-33762
Debian:13golang-github-go-git-go-gitno fix listedDEBIAN-CVE-2026-33762
Debian:14golang-github-go-git-go-git5.17.1-1DEBIAN-CVE-2026-33762
Gogithub.com/go-git/go-gitno fix listedGO-2026-4909
Gogithub.com/go-git/go-git/v4no fix listedGO-2026-4909
Gogithub.com/go-git/go-git/v55.17.1GHSA-gm2x-2g9h-ccm8
Gogithub.com/go-git/go-git/v55.17.1GO-2026-4909
Ubuntu:25.10golang-github-go-git-go-gitno fix listedUBUNTU-CVE-2026-33762
Ubuntu:26.10golang-github-go-git-go-gitno fix listedUBUNTU-CVE-2026-33762

Affected products (as reported)

VendorProductVersions
go-git go-git < 5.17.1

Weakness: CWE-129 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L

References