Vulnerability · Published Mar 26, 2026 · Assigned by GitHub_M
CVE-2026-33671Picomatch has a ReDoS vulnerability via extglob quantifiers
High 7.5
In plain English
A high-severity regular-expression denial of service in picomatch from micromatch. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Picomatch is a glob matcher written JavaScript. Versions prior to 4.0.4, 3.0.2, and 2.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) when processing crafted extglob patterns. Certain patterns using extglob quantifiers such as `+()` and `*()`, especially when combined with overlapping alternatives or nested extglobs, are compiled into regular expressions that can exhibit catastrophic backtracking on non-matching input. Applications are impacted when they allow untrusted users to supply glob patterns that are passed to `picomatch` for compilation or matching. In those cases, an attacker can cause excessive CPU consumption and block the Node.js event loop, resulting in a denial of service. Applications that only use trusted, developer-controlled glob patterns are much less likely to be exposed in a security-relevant way. This issue is fixed in picomatch 4.0.4, 3.0.2 and 2.3.2. Users should upgrade to one of these versions or later, depending on their supported release line. If upgrading is not immediately possible, avoid passing untrusted glob patterns to `picomatch`. Possible mitigations include disabling extglob support for untrusted patterns by using `noextglob: true`, rejecting or sanitizing patterns containing nested extglobs or extglob quantifiers such as `+()` and `*()`, enforcing strict allowlists for accepted pattern syntax, running matching in an isolated worker or separate process with time and resource limits, and applying application-level request throttling and input validation for any endpoint that accepts glob patterns.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-anymatch | no fix listed | DEBIAN-CVE-2026-33671 |
| Debian:13 | node-anymatch | no fix listed | DEBIAN-CVE-2026-33671 |
| Debian:14 | node-anymatch | 3.1.3+~cs8.0.6-1 | DEBIAN-CVE-2026-33671 |
| Ubuntu:22.04:LTS | node-anymatch | no fix listed | UBUNTU-CVE-2026-33671 |
| Ubuntu:24.04:LTS | node-anymatch | no fix listed | UBUNTU-CVE-2026-33671 |
| Ubuntu:25.10 | node-anymatch | no fix listed | UBUNTU-CVE-2026-33671 |
| Ubuntu:26.04:LTS | node-anymatch | no fix listed | UBUNTU-CVE-2026-33671 |
| npm | picomatch | 2.3.2 | GHSA-c2c7-rcm5-vvqj |
| npm | picomatch | 3.0.2 | GHSA-c2c7-rcm5-vvqj |
| npm | picomatch | 4.0.4 | GHSA-c2c7-rcm5-vvqj |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| micromatch | picomatch | >= 4.0.0, < 4.0.4>= 3.0.0, < 3.0.2< 2.3.2 |
Weakness: CWE-1333 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H