Vulnerability · Published May 19, 2026 · Assigned by GitHub_M
CVE-2026-33633Kitty has a Heap Buffer Overflow in its Graphics Protocol Handler
High 7.5
In plain English
A high-severity heap buffer overflow in kitty from kovidgoyal. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Kitty is a cross-platform GPU based terminal. Versions 0.46.2 and below contain a heap buffer overflow in load_image_data() that allows any process which can write to the terminal's stdin to crash kitty immediately. The vulnerability is triggered by a single APC graphics protocol command with a PNG format declaration (f=100) whose payload exceeds twice the initial buffer capacity. The overflow is attacker-controlled in both length and content, causing DoS and potentially escalation to RCE itself. This issue has been fixed in version 0.47.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | kitty | no fix listed | DEBIAN-CVE-2026-33633 |
| Debian:13 | kitty | 0.41.1-2+deb13u1 | DEBIAN-CVE-2026-33633 |
| Debian:14 | kitty | 0.47.0-1 | DEBIAN-CVE-2026-33633 |
| Ubuntu:25.10 | kitty | 0.41.1-2+deb13u1build0.25.10.1 | UBUNTU-CVE-2026-33633 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| kovidgoyal | kitty | < 0.47.0 |
Weakness: CWE-122 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H