Vulnerability · Published Mar 24, 2026 · Assigned by GitHub_M
CVE-2026-33498Parse Server: Query condition depth bypass via pre-validation transform pipeline
High 8.7
In plain English
A high-severity security flaw in parse-server from parse-community. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.55 and 9.6.0-alpha.44, an attacker can send an unauthenticated HTTP request with a deeply nested query containing logical operators to permanently hang the Parse Server process. The server becomes completely unresponsive and must be manually restarted. This is a bypass of the fix for CVE-2026-32944. This issue has been patched in versions 8.6.55 and 9.6.0-alpha.44.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | parse-server | 9.6.0-alpha.44 | GHSA-9fjp-q3c4-6w3j |
| npm | parse-server | 8.6.55 | GHSA-9fjp-q3c4-6w3j |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| parse-community | parse-server | < 8.6.55>= 9.0.0, < 9.6.0-alpha.44 |
Weakness: CWE-674 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-9fjp-q3c4-6w3j x_refsource_CONFIRM
- https://github.com/parse-community/parse-server/pull/10257 x_refsource_MISC
- https://github.com/parse-community/parse-server/pull/10258 x_refsource_MISC
- https://github.com/parse-community/parse-server/commit/2581b5426047ce9cbcd3d9c0e8379e9c30e23ab5 x_refsource_MISC
- https://github.com/parse-community/parse-server/commit/85994eff9e7b34cac7e1a2f5791985022a1461d1 x_refsource_MISC