Vulnerability · Published May 29, 2026 · Assigned by CERT-PL
CVE-2026-33386XSS in QuickCMS
Low 2.3
In plain English
A low-severity cross-site scripting in QuickCMS from OpenSolution. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities).
Official description
QuickCMS is vulnerable to Cross-Site Scripting (XSS) through its insecure HTTP-based plugin‑fetching mechanism. A malicious attacker can perform a Man‑in‑the‑Middle (MITM) attack by impersonating the opensolution.org server and serving arbitrary HTML or JavaScript at the plugin list endpoint. When a user accesses the plugin page, the malicious content is automatically fetched, rendered, and executed. This issue was fixed in a patch to version 6.8 published on 15.05.2026, deployments without this patch are still vulnerable.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenSolution | QuickCMS | 0 – through 6.8 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
References
- https://cert.pl/posts/2026/05/CVE-2026-33384/ third-party-advisory
- https://opensolution.org/home.html product