Vulnerability · Published Mar 24, 2026 · Assigned by GitHub_M
CVE-2026-33347league/commonmark has an embed extension allowed_domains bypass
Medium 6.3
In plain English
A medium-severity cross-site scripting in commonmark from thephpleague. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
league/commonmark is a PHP Markdown parser. From version 2.3.0 to before version 2.8.2, the DomainFilteringAdapter in the Embed extension is vulnerable to an allowlist bypass due to a missing hostname boundary assertion in the domain-matching regex. An attacker-controlled domain like youtube.com.evil passes the allowlist check when youtube.com is an allowed domain. This issue has been patched in version 2.8.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-league-commonmark | 2.3.9-1+deb12u1 | DEBIAN-CVE-2026-33347 |
| Debian:13 | php-league-commonmark | 2.7.0-1+deb13u1 | DEBIAN-CVE-2026-33347 |
| Debian:14 | php-league-commonmark | 2.8.2-1 | DEBIAN-CVE-2026-33347 |
| Packagist | league/commonmark | 2.8.2 | GHSA-hh8v-hgvp-g3f5 |
| Ubuntu:25.10 | php-league-commonmark | no fix listed | UBUNTU-CVE-2026-33347 |
| Ubuntu:26.04:LTS | php-league-commonmark | no fix listed | UBUNTU-CVE-2026-33347 |
| Ubuntu:26.10 | php-league-commonmark | no fix listed | UBUNTU-CVE-2026-33347 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| thephpleague | commonmark | >= 2.3.0, < 2.8.2 |
Weakness: CWE-79, CWE-185, CWE-918 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N