Vulnerability · Published Apr 17, 2026 · Assigned by GitHub_M

CVE-2026-33337Firebird has a buffer overflow when parsing corrupted slice packets

High 7.5

In plain English

A high-severity buffer overflow in firebird from FirebirdSQL. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 54.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, when deserializing a slice packet, the xdr_datum() function does not validate that a cstring length conforms to the slice descriptor bounds, allowing a cstring longer than the allocated buffer to overflow it. An unauthenticated attacker can exploit this by sending a crafted packet to the server, potentially causing a crash or other security impact. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12firebird3.0no fix listedDEBIAN-CVE-2026-33337
Debian:13firebird3.0no fix listedDEBIAN-CVE-2026-33337
Debian:14firebird3.03.0.14.ds7-1DEBIAN-CVE-2026-33337
Debian:13firebird4.0no fix listedDEBIAN-CVE-2026-33337
Debian:14firebird4.04.0.7.3271.ds6-1DEBIAN-CVE-2026-33337
Ubuntu:22.04:LTSfirebird3.0no fix listedUBUNTU-CVE-2026-33337
Ubuntu:24.04:LTSfirebird3.0no fix listedUBUNTU-CVE-2026-33337
Ubuntu:25.10firebird3.0no fix listedUBUNTU-CVE-2026-33337
Ubuntu:26.04:LTSfirebird3.0no fix listedUBUNTU-CVE-2026-33337
Ubuntu:26.10firebird3.0no fix listedUBUNTU-CVE-2026-33337
Ubuntu:25.10firebird4.0no fix listedUBUNTU-CVE-2026-33337
Ubuntu:26.04:LTSfirebird4.0no fix listedUBUNTU-CVE-2026-33337
Ubuntu:26.10firebird4.0no fix listedUBUNTU-CVE-2026-33337

Affected products (as reported)

VendorProductVersions
FirebirdSQL firebird >= 3.0.0, < 3.0.14>= 4.0.0, < 4.0.7>= 5.0.0, < 5.0.4

Weakness: CWE-120, CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References