Vulnerability · Published Jul 20, 2026 · Assigned by GitHub_M

CVE-2026-33327Possible integer overflow leading to potential heap-based buffer overflow

High 7.0

In plain English

A high-severity integer overflow in libvips from libvips. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.0High
Exploit odds (30 days)0.2%top 95.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

libvips is a fast image processing library with low memory needs. The `vipsload` operation in versions before and including 8.18.0 could incorrectly determine image dimensions leading to an integer overflow and a subsequent heap-based buffer overflow. This has been patched in version 8.18.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12vipsno fix listedDEBIAN-CVE-2026-33327
Debian:13vips8.16.1-1+deb13u2DEBIAN-CVE-2026-33327
Debian:14vips8.18.1-1DEBIAN-CVE-2026-33327

Affected products (as reported)

VendorProductVersions
libvips libvips <= 8.18.0

Weakness: CWE-190 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N

References