Vulnerability · Published Apr 8, 2026 · Assigned by GitHub_M

CVE-2026-33229XWiki Platform affected by remote code execution with script right through unprotected Velocity scripting API

Critical 9.8

In plain English

A critical-severity missing authorization in xwiki-platform-legacy-oldcore from org.xwiki.platform. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.8Critical
Exploit odds (30 days)0.5%top 53.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Prior to 17.4.8 and 17.10.1, an improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. This vulnerability is fixed in 17.4.8 and 17.10.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.xwiki.platform:xwiki-platform-legacy-oldcore17.4.8GHSA-h259-74h5-4rh9
Mavenorg.xwiki.platform:xwiki-platform-legacy-oldcore17.10.1GHSA-h259-74h5-4rh9
Mavenorg.xwiki.platform:xwiki-platform-oldcore17.4.8GHSA-h259-74h5-4rh9
Mavenorg.xwiki.platform:xwiki-platform-oldcore17.10.1GHSA-h259-74h5-4rh9

Affected products (as reported)

VendorProductVersions
xwiki xwiki-platform >= 17.0.0-rc-1, < 17.4.8>= 17.5.0-rc-1, < 17.10.1
org.xwiki.platform xwiki-platform-legacy-oldcore >= 17.0.0-rc-1, < 17.4.8>= 17.5.0-rc-1, < 17.10.1
org.xwiki.platform xwiki-platform-oldcore >= 17.0.0-rc-1, < 17.4.8>= 17.5.0-rc-1, < 17.10.1

Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References