Vulnerability · Published Apr 15, 2026 · Assigned by GitHub_M
CVE-2026-33220Weblate: JavaScript localization CDN add-on allows arbitrary local file read outside the repository
Medium 6.8
In plain English
A medium-severity path traversal in weblate from WeblateOrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Weblate is a web based localization tool. In versions prior to 5.17, the translation memory API exposed unintended endpoints, which in turn didn't perform proper access control. This issue has been fixed in version 5.17. If developers are unable to update immediately, they can disable this feature as the CDN add-on is not enabled by default.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | weblate | 5.17 | GHSA-mqph-7h49-hqfm |
| PyPI | weblate | 5.17 | PYSEC-2026-153 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| WeblateOrg | weblate | < 5.17 |
Weakness: CWE-22, CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
References
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-mqph-7h49-hqfm x_refsource_CONFIRM
- https://github.com/WeblateOrg/weblate/pull/18516 x_refsource_MISC