Vulnerability · Published Apr 15, 2026 · Assigned by GitHub_M
CVE-2026-33214Weblate has improper access control for the translation memory API
Medium 4.3
In plain English
A medium-severity missing authorization in weblate from WeblateOrg. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Weblate is a web based localization tool. In versions prior to 5.17, the translation memory API exposed unintended endpoints, which in turn didn't enforce proper access control. This issue has been fixed in version 5.17. If users are unable to update immediately, they can work around this issue by blocking access to /api/memory/ in the HTTP server, which removes access to this feature.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | weblate | 5.17 | GHSA-mpf5-3vph-q75r |
| PyPI | weblate | 5.17 | PYSEC-2026-152 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| WeblateOrg | weblate | < 5.17 |
Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
References
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-mpf5-3vph-q75r x_refsource_CONFIRM
- https://github.com/WeblateOrg/weblate/pull/18513 x_refsource_MISC