Vulnerability · Published Apr 3, 2026 · Assigned by GitHub_M
CVE-2026-33175OAuthenticator: Authentication Bypass in Auth0OAuthenticator via Unverified Email Claims
High 8.8
In plain English
A high-severity improper authentication in oauthenticator from jupyterhub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
OAuthenticator is software that allows OAuth2 identity providers to be plugged in and used with JupyterHub. Prior to version 17.4.0, an authentication bypass vulnerability in oauthenticator allows an attacker with an unverified email address on an Auth0 tenant to login to JupyterHub. When email is used as the usrname_claim, this gives users control over their username and the possibility of account takeover. This issue has been patched in version 17.4.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | oauthenticator | 17.4.0 | GHSA-rrvg-cxh4-qhrv |
| PyPI | oauthenticator | 17.4.0 | PYSEC-2026-2238 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jupyterhub | oauthenticator | < 17.4.0 |
Weakness: CWE-287, CWE-290 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H