Vulnerability · Published Mar 20, 2026 · Assigned by GitHub_M

CVE-2026-33151socket.io allows an unbounded number of binary attachments

High 8.7

In plain English

A high-severity improper input validation in socket.io from socketio. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.7High
Exploit odds (30 days)0.5%top 54.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Socket.IO is an open source, real-time, bidirectional, event-based, communication framework. Prior to versions 3.3.5, 3.4.4, and 4.2.6, a specially crafted Socket.IO packet can make the server wait for a large number of binary attachments and buffer them, which can be exploited to make the server run out of memory. This issue has been patched in versions 3.3.5, 3.4.4, and 4.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-socket.io-parserno fix listedDEBIAN-CVE-2026-33151
Debian:13node-socket.io-parserno fix listedDEBIAN-CVE-2026-33151
Debian:14node-socket.io-parser4.2.1+~3.1.0-4DEBIAN-CVE-2026-33151
Ubuntu:22.04:LTSnode-socket.io-parserno fix listedUBUNTU-CVE-2026-33151
Ubuntu:24.04:LTSnode-socket.io-parserno fix listedUBUNTU-CVE-2026-33151
Ubuntu:25.10node-socket.io-parserno fix listedUBUNTU-CVE-2026-33151
Ubuntu:26.04:LTSnode-socket.io-parserno fix listedUBUNTU-CVE-2026-33151
npmsocket.io-parser4.2.6GHSA-677m-j7p3-52f9
npmsocket.io-parser3.4.4GHSA-677m-j7p3-52f9
npmsocket.io-parser3.3.5GHSA-677m-j7p3-52f9

Affected products (as reported)

VendorProductVersions
socketio socket.io < 3.3.5>= 3.4.0, < 3.4.4>= 4.0.0, < 4.2.6

Weakness: CWE-20, CWE-754 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References