Vulnerability · Published Mar 20, 2026 · Assigned by GitHub_M
CVE-2026-33036fast-xml-parser affected by numeric entity expansion bypassing all entity expansion limits (incomplete fix for CVE-2026-26278)
High 7.5
In plain English
A high-severity security flaw in fast-xml-parser from NaturalIntelligence. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
fast-xml-parser allows users to process XML from JS object without C/C++ based libraries or callbacks. Versions 4.0.0-beta.3 through 5.5.5 contain a bypass vulnerability where numeric character references (&#NNN;, &#xHH;) and standard XML entities completely evade the entity expansion limits (e.g., maxTotalExpansions, maxExpandedLength) added to fix CVE-2026-26278, enabling XML entity expansion Denial of Service. The root cause is that replaceEntitiesValue() in OrderedObjParser.js only enforces expansion counting on DOCTYPE-defined entities while the lastEntities loop handling numeric/standard entities performs no counting at all. An attacker supplying 1M numeric entity references like A can force ~147MB of memory allocation and heavy CPU usage, potentially crashing the process—even when developers have configured strict limits. This issue has been fixed in version 5.5.6.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-webfont | no fix listed | DEBIAN-CVE-2026-33036 |
| Debian:13 | node-webfont | no fix listed | DEBIAN-CVE-2026-33036 |
| Debian:14 | node-webfont | no fix listed | DEBIAN-CVE-2026-33036 |
| Ubuntu:24.04:LTS | node-webfont | no fix listed | UBUNTU-CVE-2026-33036 |
| Ubuntu:25.10 | node-webfont | no fix listed | UBUNTU-CVE-2026-33036 |
| Ubuntu:26.04:LTS | node-webfont | no fix listed | UBUNTU-CVE-2026-33036 |
| Ubuntu:26.10 | node-webfont | no fix listed | UBUNTU-CVE-2026-33036 |
| npm | fast-xml-parser | 4.5.5 | GHSA-8gc5-j5rx-235r |
| npm | fast-xml-parser | 5.5.6 | GHSA-8gc5-j5rx-235r |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| NaturalIntelligence | fast-xml-parser | >= 4.0.0-beta.3, < 5.5.6 |
Weakness: CWE-776 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/NaturalIntelligence/fast-xml-parser/security/advisories/GHSA-8gc5-j5rx-235r x_refsource_CONFIRM
- https://github.com/NaturalIntelligence/fast-xml-parser/commit/bd26122c838e6a55e7d7ac49b4ccc01a49999a01 x_refsource_MISC
- https://github.com/NaturalIntelligence/fast-xml-parser/releases/tag/v5.5.6 x_refsource_MISC