Vulnerability · Published Mar 30, 2026 · Assigned by GitHub_M
CVE-2026-33027Nginx UI: Improper Path Validation Allows Recursive Deletion of the Nginx Configuration Directory
Medium 6.9
In plain English
A medium-severity path traversal in nginx-ui from 0xJacky. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities).
Official description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui configuration improperly handles URL-encoded traversal sequences. When specially crafted paths are supplied, the backend resolves them to the base Nginx configuration directory and executes the operation on the base directory (/etc/nginx). In particular, this allows an authenticated user to remove the entire /etc/nginx directory, resulting in a partial Denial of Service. This issue has been patched in version 2.3.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/0xJacky/Nginx-UI | no fix listed | GHSA-m8p8-53vf-8357 |
| Go | github.com/0xJacky/Nginx-UI | no fix listed | GO-2026-4907 |
Affected products (as reported)
Weakness: CWE-22, CWE-73 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-m8p8-53vf-8357 x_refsource_CONFIRM
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.4 x_refsource_MISC