Vulnerability · Published Mar 30, 2026 · Assigned by GitHub_M
CVE-2026-33026nginx-ui Backup Restore Allows Tampering with Encrypted Backups
Critical 9.4
In plain English
A critical-severity security flaw in nginx-ui from 0xJacky. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)9.4Critical
Exploit odds (30 days)0.3%top 73.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.4, the nginx-ui backup restore mechanism allows attackers to tamper with encrypted backup archives and inject malicious configuration during restoration. This issue has been patched in version 2.3.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/0xJacky/Nginx-UI | 1.9.10-0.20260315015203-f61bcec547c0 | GHSA-fhh2-gg7w-gwpq |
| Go | github.com/0xJacky/Nginx-UI | no fix listed | GO-2026-4903 |
Affected products (as reported)
Weakness: CWE-312, CWE-347, CWE-354 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
References
- https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-fhh2-gg7w-gwpq x_refsource_CONFIRM
- https://github.com/0xJacky/nginx-ui/releases/tag/v2.3.4 x_refsource_MISC