Vulnerability · Published Apr 14, 2026 · Assigned by GitHub_M

CVE-2026-33020libsixel: Integer Overflow in write_png_to_file() leads to Heap-based Buffer Overflow

High 7.1

In plain English

A high-severity heap buffer overflow in libsixel from saitoha. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 11% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.2%top 89.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel. Versions 1.8.7 and prior contain an integer overflow which leads to a heap buffer overflow via sixel_frame_convert_to_rgb888() in frame.c, where allocation size and pointer offset computations for palettised images (PAL1, PAL2, PAL4) are performed using int arithmetic before casting to size_t. For images whose pixel count exceeds INT_MAX / 4, the overflow produces an undersized heap allocation for the conversion buffer and a negative pointer offset for the normalization sub-buffer, after which sixel_helper_normalize_pixelformat() writes the full image data starting from the invalid pointer, causing massive heap corruption confirmed by ASAN. An attacker providing a specially crafted large palettised PNG can corrupt the heap of the victim process, resulting in a reliable crash and potential arbitrary code execution. This issue has been fixed in version 1.8.7-r1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12libsixelno fix listedDEBIAN-CVE-2026-33020
Debian:13libsixelno fix listedDEBIAN-CVE-2026-33020
Debian:14libsixel1:1.8.7-r2-1DEBIAN-CVE-2026-33020
Ubuntu:22.04:LTSlibsixelno fix listedUBUNTU-CVE-2026-33020
Ubuntu:24.04:LTSlibsixelno fix listedUBUNTU-CVE-2026-33020
Ubuntu:25.10libsixelno fix listedUBUNTU-CVE-2026-33020
Ubuntu:26.04:LTSlibsixelno fix listedUBUNTU-CVE-2026-33020
Ubuntu:26.10libsixelno fix listedUBUNTU-CVE-2026-33020

Affected products (as reported)

VendorProductVersions
saitoha libsixel < 1.8.7-r1

Weakness: CWE-122, CWE-190 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H

References