Vulnerability · Published Apr 9, 2026 · Assigned by apache

CVE-2026-33005Apache OpenMeetings: Insufficient checks in FileWebService

Medium 4.3

In plain English

A medium-severity security flaw in Apache OpenMeetings from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.4%top 63.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Handling of Insufficient Privileges vulnerability in Apache OpenMeetings. Any registered user can query web service with their credentials and get files/sub-folders of any folder by ID (metadata only NOT contents). Metadata includes id, type, name and some other field. Full list of fields get be checked at FileItemDTO object. This issue affects Apache OpenMeetings: from 3.10 before 9.0.0. Users are recommended to upgrade to version 9.0.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.openmeetings:openmeetings-parent9.0.0GHSA-78cg-fc6c-w44w

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache OpenMeetings 3.1.0 – before 9.0.0

Weakness: CWE-274 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

References